Workday slowness and errors
Incident Report for PGA of America
Resolved
Workday has resolved the issue.
Posted Apr 04, 2023 - 09:15 EDT
Investigating
We are currently investigating this issue.
Posted Apr 03, 2023 - 11:35 EDT
This incident affected: Workday (Workday Production Tenant).