Ring Central Phone Service Outage
Incident Report for PGA of America
Resolved
This issue has been resolved by the vendor at this time.
Posted Mar 26, 2020 - 22:30 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2020 - 12:51 EDT
Identified
Ring Central is experiencing outages that will affect logging into to the Ring Central phone app as well as call functionality. The mobile app seems to be experiencing less issues and would be a good temporary alternatively until this is resolved by the vendor. Note: this is mostly caused by root issues with phone and internet services across the board due to overwhelming bandwidth demands.
Posted Mar 26, 2020 - 12:50 EDT
This incident affected: Ring Central Phones.